We're pleased to let you know that the issues affecting our network have been resolved, and all services are now fully operational.
Posted Mar 26, 2025 - 15:12 CET
Update
The issue with our SIM card provider, Onomondo, has now stabilized. All services are operational, and devices should come back online on the next authentication attempt.
We will continue to monitor network performance closely during the coming period to ensure full stability.
Posted Mar 26, 2025 - 13:04 CET
Identified
Our SIM card provider, Onomondo, has identified the issue, and they expect charge points to start reconnecting soon.
They are actively working on full resolution, and we will continue to monitor the situation closely.
Posted Mar 26, 2025 - 11:16 CET
Investigating
Our SIM card provider, Onomondo, is currently experiencing outages affecting multiple charge points. This may result in longer authentication times or dropped connections.
Onomondo is actively working to resolve the issue, and we are closely monitoring the situation. We will provide updates as soon as more information becomes available.