Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 06:00 CET
Scheduled
On Wednesday, March 26th, from 6 to 7 AM, our Cloud Team will be upgrading our system. We don’t expect any disruptions or issues, but there is a small chance that some parts of the charging process could be affected. If that happens, we’ll work quickly to fix it within the maintenance window.
Chargers will stay connected throughout, as the system responsible for that won’t be impacted by this update.
Posted Mar 21, 2025 - 13:02 CET
This scheduled maintenance affected: Charge Point Network - All.