Service disruption

Incident Report for Spirii

Postmortem

Summary

As part of planned infrastructure maintenance, we upgraded our core database engine overnight on 20–21 August. The database migration itself completed cleanly with no data or write interruption.

Following the migration, a subset of backend services experienced connectivity issues due to client-library compatibility requirements introduced by the upgrade. This resulted in intermittent failures for charging session starts, pricing retrieval, and portal/app responsiveness between 08:17 and 09:23 CEST.

Resolution

Our engineering team identified the affected services and deployed targeted fixes. Full service recovery was confirmed at 09:23 CEST, with continued monitoring through the morning to ensure stability.

Follow-up

We are formalizing additional pre-deployment compatibility checks for future infrastructure upgrades to prevent recurrence.

We apologize for any disruption to operations.

Please contact your Spirii account / rollout manager or our support team with any follow-up questions.

Posted Aug 21, 2026 - 10:50 CEST

Resolved

The incident has been fully resolved, and all services are operating normally. We will continue to monitor the platform to ensure continued stability.
Posted Aug 21, 2026 - 09:42 CEST

Monitoring

We are seeing service recovery across the platform. The fix appears to have resolved the issue, and we are continuing to closely monitor all systems to ensure stability.
Posted Aug 21, 2026 - 09:27 CEST

Identified

We have identified the issue and are currently deploying a fix. Services are expected to gradually recover as the deployment progresses. We will provide another update once the deployment has been completed.
Posted Aug 21, 2026 - 09:23 CEST

Investigating

We are currently experiencing issues affecting core platform functionality.
We are actively investigating and will provide updates as available.
Posted Aug 21, 2026 - 08:53 CEST
This incident affected: Charge Point Network - All, Charging Apps, Connect Portal, Roaming services, and Public APIs.